Hand-selected, original logos for sale
Once it's sold, it's gone!
Forum Questions, ideas and bug reports


DESIGNER

Ortega Graphics
2017-03-09

Hello,

Here are some questions, ideas and bug reports I wanted to share. Comments from the community are welcome.

1) Currently, the indexation of words for the internal search engine includes subsets of words. I suspect this is because of plurals (thus, an internal search for "lion" will also yield logos with the word "lions"). Alternatively, the algorithm for index look-up includes partial words. But, this becomes problematic when the results are irrelevant. Currently, as an example, a search for "king" yields irrelevant logos featuring the words "cooking" or "networking" and thus, to an unsuspecting client, this might seem like an error in the system. Have you considered changing this behavior in the indexation/look-up of words?

2) On the Views counter of each logo page, wouldn't it be a good idea if views from designers be excluded from the total views of logos? That is, maybe the system should only count views from members that have never submitted a logo, along with non-members (anonymous, not-logged users). This way, that number on the Views counter will reflect only real client interest (removing our own views and fellow designers' views). By the way, I suspect that the number of actual designers that also buy logos is negligible.

3) It not already done, maybe the same should be applied to any existing keyword counter. That is, designers' searches for common words (e.g., mountain, horse, dog, real estate, etc.) should not be counted and thus, these searches won't skew the maintained list of top searchers from actual clients.

4) On search results, on the rollover preview (when hovering the magnifying glass on top of thumbnails), the logo name appears at the bottom only the first time the user hovers; any further hover doesn't include the logo name. It's not a huge bug, but it might be confusing/annoying to some clients.

5) Currently, there is an unnecessary "s" character at the bottom of this page (before the footer): http://www.logoground.com/community.php

6) On the "More of these logos!" topic (http://www.logoground.com/discuss.php?topic=75), it was mentioned that LogoGround has a system that picks up on the word "letter" and makes the logo searchable if someone searches for just a letter. Currently, it seems that this system is failing as one-letter search results do not include the letter logos submitted in the past 2-3 weeks.

7) Do you check your spam often? I sent you an email and two followup emails in the past 10 days or so (directly, and using the form). No rush; I would understand if it takes time to answer emails, but I am worried that my emails have been erroneously filtered by your email software.

Thank you for your time and keep up the excellent work.

Peace,

Ortega Graphics



ADMIN
ajleroux
2017-03-09

Hi Ortega Graphics,

Thanks for the awesome feedback!

1) In the early days of LG we had few logos so it made more sense to do it this way, but it's due for a rethink. It's on our to-do list.

2) Yes, good suggestion. We are redesigning the whole likes/views system to be more streamlined and we will introduce a feature where it's possible to follow designers. When this update is done the view counter will not count all views. It will still count views from designers, but it will be limited so that designers can't skew the results too much.

3) That's one we haven't thought of before. Good idea, thanks. Adding it to our to-do list.

4) The disappearing title is a mystery. I have spent many hours hunting that bug :)

5) Fixed. Thanks.

6) There's a manual step in the process and the person responsible for "letter-logo-fication" returned from leave today. We will catch up with the overdue logos in the next day or two.

7) The same person is partly responsible for designer support so you should receive replies shortly! :) Normal turnaround for email support is one business day.

Thanks again for the feedback!



DESIGNER
Ortega Graphics
2017-03-11

Hi André,

Regarding #4. I had some time today and I checked your code. I am not a web developer (I am a designer who enjoys coding once in a while), so you might be surprised to learn that it took me less than a minute to find the "bug"; I realized that there is one line of jQuery code that is unnecessary in your case.

As a test, I added two slashes in front to convert that line to a single-line comment on a local copy of the code. Immediately, the title (logo name) inside the hovering preview worked as expected. That is, on my local copy, the logo name now shows on the first hover as well as on all further hovers; even after several hover/unhover cycles on multiple logo previews.

The line in question is line 23 of the file main.js
this.title = "";
It seems that the purpose of this line was to avoid showing the previously stored name (title) if a new image preview call was missing the title attribute. But this is not necessary in your case, as all image preview calls have the title attribute properly added to the html code (which is dynamically created by your php code).

As indicated above, I added two slashes in front of that line to convert it to a single-line comment (as good practice, I like to keep the original code for future reference):
// this.title = "";

Works perfectly on all common browsers (I tried it locally on Chrome, Firefox, Safari, Opera and IE).

Mystery solved. :o)

Ortega Graphics



ADMIN
ajleroux
2017-03-11

Ortega Graphics, many thanks for taking the time!
Commenting out that line did it.
Mystery solved, code fixed. :)



DESIGNER
Ortega Graphics
2017-03-11

Hi André,

Turns out that the real purpose of line 23 was not what I suspected. The real reason to make the title attribute blank was to avoid the browser showing the standard tooltip containing the contents of the title attribute (plus URL in some browsers). This is why the title was and is tried to be (unsuccessfully) restored on line 32. So, now that we commented line 23, all browsers show the standard tooltip; which might be annoying to some users. In Chrome, it takes about 1.5 seconds to appear, so some users might not see it. I suggest we fix this. :o)

So, for some reason the restoration on line 32 is failing (this is the real reason why the second hover didn't have the title). I suspect that it is because of the way the value is stored. There is a more elegant way of storing the value on a separate temporary attribute.

Too new lines of code are required. Here's how to do it:

First, what is currently line 23:
//this.title = "";
Is changed to these two lines, notice I uncommented the line and added the new line before it:
$(this).attr("temp_title", $(this).attr("title"));
this.title = "";

Second, what is currently line 32:
this.title = this.t;
Is changed to these two lines, notice I have commented the line and added the new line after it:
//this.title = this.t;
$(this).attr("title", $(this).attr("temp_title"));

I have tried this and it works perfectly; the title attribute is stored in a temporary attribute called temp_title and then the original title attribute is temporarily removed while showing the image preview (as it was in the original code), then it is successfully restored when the hover is done (better than the original code).

New tiny bug, fixed. :o)

Ortega Graphics



ADMIN
ajleroux
2017-03-13

Hi Ortega Graphics,

Javascript really isn't my thing so your help with this is greatly appreciated.

I made those changes and it looks like it works 100% now.

Thanks again!



DESIGNER
xDick
2017-04-25

Hi, LogoGround!

I have a question about profile page. Why logos aren't sorted there by date like it was before? As for me it looks weird a bit.
What do you think about it?



ADMIN
ajleroux
2017-04-25

Hi xDick,

We are in the process of trying to improve the profile page. One of the things we have changed is the sort order. We want the designer's best logos at the top so that a buyer's first impression is good. Our logo ranking algorithm sorts the logos. I think it does a reasonable job of ranking the logos, but there is room for improvement there. We could probably also include a drop-down that lets the user choose the sort order, like we have on the main logos page.

Thanks for the feedback!



DESIGNER
xDick
2017-04-25

Oh, now I see. In my opinion drop-down would be a very good improvement there.

Thank you for what you're doing.
Have a great day, @ajleroux!



ADMIN
ajleroux
2017-04-25

Thanks xDick, you too :)



DESIGNER
xDick
2017-11-17

Hello, LogoGround, haven't seen you for ages!
I would like to thank you for the drop-down improvement, but I there is a bug: when you choose sorting by newest/oldest logos and try to navigate to other pages, sorting settings restore to the defaults (by Ranking). Could you please fix that?



ADMIN
ajleroux
2017-11-17

Hello xDick, welcome back!

Thanks for reporting the error. Code updated. It should work now.



DESIGNER
Ortega Graphics
2017-11-17

Hello André,

Yes. I can confirm that this is now fixed on a designer's private "my logos" page (the "o" parameter is properly set). Thank you.

But this bug seems to still be present on a designer's public portfolio. That is, after sorting by "newest first" or "oldest first", the navigation links at the bottom of the page (green page numbers) are missing the "orderby" parameter.

Ortega Graphics



ADMIN
ajleroux
2017-11-18

Ah, thanks Ortega Graphics. Fixed.



DESIGNER
xDick
2017-12-13

@mc design stated at a neighbouring thread:
"When browsing logos on the new site, the logos on the right side are not visible completely.
See link http://prntscr.com/h0b055"

I know @ajleroux said that it's something you need to improve, but I just wanted to remind that there is still an issue with popup previews.



ADMIN
ajleroux
2017-12-14

Thanks xDick. It's on our to-do list.



DESIGNER
xDick
2017-12-14

Good to hear that. Keep up the great work on the site!



DESIGNER
explogos
2018-01-16

I couldn't find this reported anywhere (maybe I'm the only one?) but, every time I message a client during the process of completing a sale, I am logged out of the site.



ADMIN
ajleroux
2018-01-16

Hi Steve,

That's a bug we haven't seen before. Please let me know the URL of the page and the sequence of actions so that I can try to replicate it.



DESIGNER
explogos
2018-01-16

Hi AJ,

I haven't repeated this since, because I don't have anything new to say to the client just yet, but I received a sales notification email over night and the precise sequence I followed this morning was:

- Open up 'My LogoGround' from my favourites (takes me directly to my dashboard)
- Click the 'view' button beneath 'Sales'
- Click the hyperlink of the latest sale
- Click 'Design Brief' button (the default view is 'Revisions')
- Click back to 'Revisions' and typed a comment
- Click 'Post Message'
- the next page load notified me that my message had been sent but, at this point, I was no longer logged in.

Although I can't say categorically that I followed this exact sequence in the past, I was logged out in a similar manner throughout the course of my last project.

Hope this helps. :)



ADMIN
ajleroux
2018-01-16

Many thanks for the report. Sounds like it is related to our "remember me" cookie. I'll investigate.



DESIGNER
Old Boy
2018-01-16

With several operations is the same. For example, when I enter Designer forum I am logged out.



DESIGNER
Brandmaistro
2018-01-16

Is it possible to add some buttons next to the logo, so we can share it ons the well known social (pinterest, FB, twitter, ...)?
Saves a lot of time ;-)



DESIGNER
Brandmaistro
2018-01-16

Is it possible to add some buttons next to the logo, so we can share it ons the well known social (pinterest, FB, twitter, ...)?
Saves a lot of time ;-)



DESIGNER
eclipse42
2018-01-17

You have pinterest button in upper left corner of the logo when you get your cursor over the logo.



ADMIN
LogoGround
2018-01-17

Thank you for the suggestion. I am adding it to our development to-do list.



DESIGNER
Brandmaistro
2018-01-17

@Eclipse42
You are right!
Okay okay, just a FB en TW button then... ;-)



DESIGNER
Furqontino
2019-11-06

I recently wanted to see new designers at LG by clicking on the last page of the "Other Designers" button (page 253)

I am surprised that there is a Designer with Silver Badges, 1 year member, 480 logos, and 12 sold. be there
and the more surprising is, there is also one Designer with Gold Badge, 1 year member, 557 logos, 11 sold

Is that a bug or what? How did it happen?
isn't the list sorted by rank



DESIGNER
Ortega Graphics
2019-11-06

That list is sorted by reputation not by designer rank:
https://www.logoground.com/logo-designers.php

Since, designer rank is directly linked to the (hidden) reputation number, then it is normal that most of that list seems to be sorted by designer ranking, but as you noticed, there are exceptions.

The designer ranking page lists positive actions that increase a user's reputation: https://www.logoground.com/designer-ranking.php

But one can guess that some negative actions would also decrease a user's reputation. It seems that a designer rank can not be unawarded. So, a user could lose a lot of reputation points even after earning a high designer rank. Of course, the admins could confirm this.

Hope this helps,

Ortega Graphics



ADMIN
ajleroux
2019-11-06

Exactly right :)



DESIGNER
Furqontino
2019-11-07

@Ortega, that makes sense
but it's still weird and worrying if it happens to others.
we all know that means they lost more than 100 points

So, what negative actions would badly decrease the reputation of designers?
copycat, using inappropriate words in the forum, blame to the clients, or what?



ADMIN
ajleroux
2019-11-07

Simply declined logos. I designer may do well for a while and climb in the rankings, then start uploading lots of logos that are not as good. I don't understand it either! Maybe they gave the account to another designer who is not on the same skill level.

You shouldn't worry about this. It will only happen to you if you upload 100+ bad logos.



DESIGNER
Furqontino
2019-11-07

thanks, nice to hear that ;-)



DESIGNER
CrossTheLime
2020-02-12

Is this where we add our wish list? :)

I would love a better stats overview. Likes, views by not designers.



DESIGNER
Coooper
2020-02-12

Views for all logos, a graph to show views per day/week/month.

Overall “store” views. More info the better



DESIGNER
stilographic
2020-06-01

I noticed that ranking logo feature is not refreshing as usual since a week ago. Are you aware of this matter?



ADMIN
ajleroux
2020-06-01

Hi stilographic. Yup, we're aware of it, thanks. We are testing a change where the algorithm updates more gradually over seven days rather than all at once on one day. As we transition and test there may be times when it takes more than seven days to complete the update cycle, but once it runs like it should we hope to complete the update cycle much more quickly - once a day if possible.



DESIGNER
stilographic
2020-06-01

Hi Ajleroux, thanks for your response.
In my case, it seems that it's more than 7 days it's not refreshing. It's that ok?
Thanks again.



DESIGNER
stilographic
2020-07-14
Edited 2020-07-14 by stilographic permalink ANCHOR

Hi,
my current project notifications is failing. Firstly the sale wasn´t notificated and now when I respond the client and upload customizations the message shown is "You have 1 open project" when the rigth message should be "Awaiting for customer feedback".
Could you check this please?
Thanks in advance.

Message update:
I posted a new message in my project and now I don´t get the "You have 1 open project" message displaying. It seems that this way it´s working fine now but I would suggest to review this matter just in case. Also the notification about selling a logo by mail come many hours after it was started. Something is delaying the notification. Maybe you want check this issue too.

New update:
The message ""You have 1 open project" without having message from the customer has appear again. It seems that writing a message didn´t work too much. Maybe you can check to fix it.



DESIGNER
eclipse42
2020-07-14

@ajleroux, on a sold logo after sending revision and a message also, the yellow bar is still present. I tried to click on push to client (never pressed that before, but decided to try) I got an error saying "Project Selection Error

We can't find the project you are looking for!

Help us improve by reporting any problems you find on LogoGround."

So as it says, I decided to report a problem :)



DESIGNER
lazeefish
2020-07-15

Almost same problem here, after sending the final files to the client, the project re opened several times so far, I keep on pushing it to the archive but the yellow bar is still here.



DESIGNER
immoodesign
2020-07-16
Edited 2020-07-16 by immoodesign permalink ANCHOR

I'm not sure whether its been discussed or not but I think it would be good to share an idea I have in mind for long but didn't get a chance to put that in front of you guys.

I know there is already a link "Community Page(designers, sales, etc.)" but it seems limited because it does not show previously sold logos history. Why not adding a seperate 'SOLD LOGOS' link which would categorize all the sold logos/history at one page(1, 2....>>more). OR can we at least try adding a button "More Sold Logos" under the displayed sold logos page just like the designer images+more designers button showing at the top of that same page? So we can brows only the sold logos history page by page. Thanks!



DESIGNER
ava_nauval
2020-07-16

@immoodesign @ajleroux

These "sold logos" pages really really would help any designer here to increase their sales and I can't more agree with that. I'm still faithfully waiting for when the page can be realized.

Thankyou



DESIGNER
Proff!
2021-01-02
Edited 2021-01-08 by artileriprof006 permalink ANCHOR

(SOLVED) *Reporting Bugs*

There are logos that cannot appear in full.

The logo can only display the title.

I have no idea ...

Does this only happen when I play "Logo Exam".

This problem might include errors or failing to refresh.

But after I tried to find a logo with the keyword "Letter J Juice Logo", it happened again.

I even had "Refresh Browser" a few times, but the results are still the same.

Logo Exam
https://prnt.sc/wf0h35

Searching
https://prnt.sc/wf0hve

* report only



DESIGNER
Arda
2021-01-13

I just noticed that the number of logos and sales on the designer store page is listed on the right of the badges instead of below when viewed on 1280x1024 in Firefox. In Chrome it looks OK.

Here's what I mean:
https://prnt.sc/wmkmy0



DESIGNER
Ortega Graphics
2021-01-13

@Arda, try cache-refreshing your browser. https://www.google.com/search?q=cache-refresh



DESIGNER
Arda
2021-01-13

That did the trick.

Thanks



DESIGNER
doarnora
2021-01-16

I noticed something weird.

I see the views on one design, I share it on FB, it instantly grows with 5-7 plus views after refresh. The same after a tweet, or linkedin, or instagram. After these 4 shares I get a 16-20 plus views, in a matter of seconds. But almost nothing after that....

My wonder is, are these "views" real? How does this work?



ADMIN
ajleroux
2021-01-16

Hi doarnora,

That sounds about right to me. Probably those views are from your followers who happen to be on the particular platform at the moment you share it.

The views counter is just counting the number of times people open that page, counting each person only once regardless of refreshes.



DESIGNER
doarnora
2021-01-16

Thank you Andre :)



DESIGNER
UpartmanDesign
2021-01-18
Edited 2021-01-18 by UpartmanDesign permalink ANCHOR

Hi, LogoGround,
Some of my logos displayed don't have the LogoGround watermark, what's happen?

Thanks



ADMIN
ajleroux
2021-01-19

Hi UpartmanDesign,

That's just your cache showing you a local copy of the image. Try Ctrl F5 (Ctrl refresh) on the logo page to force your browser to load the newer version of the image.



DESIGNER
Proff!
2021-01-23

Report Bugs:
Image Does not Appear

I rediscovered a logo without bringing up the image.

The logo only displays the title.

Keywords: "J Face Logo"

link:
https://prnt.sc/xhvkl4

I have refreshed (F5) a few times but it still doesn't appear

Hopefully it can be resolved soon.



ADMIN
ajleroux
2021-01-23

artileriprof006, thanks for letting us know. This is a known issue, but so far we have been unable to figure out the cause. I removed the logo.



DESIGNER
Proff!
2021-01-24

@ajleroux

I hope that such 'bugs' do not detract from the reputation of the associated designer.

May you always be well, Sir.



ADMIN
ajleroux
2021-01-25

artileriprof006, no penalty for the designer. :)



DESIGNER
Enoh91
2021-02-01

ajleroux,
Responding to the previous doarnora post. about the weird stuff if we share one of our logos on Facebook, etc. There is an additional display there. I also experienced it.

Maybe you can try to share one of your logos on Facebook, before you actually share it on Facebook, refresh your logo page, and the logo is automatically increased 3 views, even if you haven't finished share it yet. Likewise if you share it on whatsapp messages. before the person you are messaging reads your message, logo view changes automatically as well +2. Likewise on twitter.



DESIGNER
Ortega Graphics
2021-02-01

Ajleroux,

Concerning the issue reported by Doarnora and Enoh91, these are not real visits by real users, these are bot visits; which are simply crawling to gathering data to populate a recently-created link or post, this happens before any real user actually clicked on said link or post.

The LG system shouldn't count these bot visits. To do this, the LG system must verify the user agent and ignore visits by specific bots. Each platform has their own bot with a unique user agent which can be easily identified; for example, here's some information about the unique user agents shown by bots from Facebook and Twitter:
https://developers.facebook.com/docs/sharing/webmasters/crawler/
https://developer.twitter.com/en/docs/twitter-for-websites/cards/guides/getting-started

Hope this helps,

Ortega Graphics



DESIGNER
itDiffers
2021-02-01

May I ask what's the harm if some of the counted views come from bots? I believe some of the logos which are here for years have already been crawled many times by bots from all over the planet.



ADMIN
ajleroux
2021-02-01
Edited 2021-02-01 by ajleroux permalink ANCHOR

Thanks for the suggestion Ortega Graphics. Added to the to-do list.

itDiffers, not much harm. We would like the views to be accurate, but views are fairly unimportant in the ranking algorithm.



DESIGNER
Hamra Design
2021-02-09

yup. like a search for letter yields logos featuring all logos with that letter



DESIGNER
Proff!
2021-05-16

The profile photo view does not appear.

I've tried opening it on PC and smartphone.
I have sent the report to the 'Report Bug' contact.

Or maybe the browser I'm using is having an error.

Hopefully it will be resolved soon.



DESIGNER
itDiffers
2021-05-16

Same here. All avatars are gone. Clearing browser cache doesn't help.



DESIGNER
rasagama
2021-05-16

I also faced the same problem



DESIGNER
rmn2971
2021-05-16

me too



DESIGNER
Frankie Soo
2021-05-16
Edited 2021-05-16 by Frankie Soo permalink ANCHOR

There are missing links for all avatars.



DESIGNER
Brandmaistro
2021-05-16
Edited 2021-05-16 by Brandmaistro permalink ANCHOR

I've uploaded my avatar and it's back now.
Did not want to wait for it so I helped myself.
Only a handful of other designers did the same. :-)
LOL



DESIGNER
skintani
2021-05-16

all the avatar rapture ... ; -)



ADMIN
ajleroux
2021-05-16
Edited 2021-05-17 by ajleroux permalink ANCHOR

Thanks everyone. We're investigating.

Edit: The missing avatar discussion continued here: https://www.logoground.com/discuss.php?topic=3610



DESIGNER
Proff!
2021-05-16

Report Bugs:
Image Does not Appear

I rediscovered a logo without bringing up the image.

The logo only displays the title.

Keywords: "lovely roses"
Error: Romantic Rose Cake Logo

Link:
https://prnt.sc/1301nsn






ADMIN
ajleroux
2021-05-17

Many thanks Proff!, that is now fixed.



DESIGNER
didiwinata
2021-06-06

The text on the logo page that is reported to look overlay overrides the menu

https://prnt.sc/14doq2i



ADMIN
ajleroux
2021-06-07

Many thanks didiwinata. It should display correctly now.



DESIGNER
eclipse42
2021-06-14

Today I typed "bull" inside the internal search to find my own logo and remove it. While typing, it wrote it backwards. On laptop it works fine, on mobile it is reversed. Is it something on my end or ?

I attached an image of it: https://ibb.co/PC6MRL9



ADMIN
ajleroux
2021-06-14

Hi eclipse42,

Thanks for letting us know. That's very strange. I've never seen it before. I've tested it on my computer and on my phone, both showing the letters the right way around. A setting on your phone perhaps?



DESIGNER
eclipse42
2021-06-14

@ajleroux I really don't know. Before it worked properly, I haven't changed anything that I know of :) What setting could even cause something like this, everywhere else it types correctly. If it is just me it is not a problem, I will use laptop for such things as I can't think of anything to fix it, to be honest. Thanks!



DESIGNER
mk4gfx
2021-06-14

Hi @ajleroux, @eclipse42,
I tried it and I got the same flipped result as @eclipse when my phone was on portrait but it worked normally when I rotated my phone to landscape. Maybe the screen size has something to do with it.



ADMIN
ajleroux
2021-06-14

Thanks mk4gfx. On my phone the search box is too small to display any text when in portrait mode.

It is difficult to fix something when we can't see and test it, but I made a small change which might fix it. Please let me know.



DESIGNER
mk4gfx
2021-06-14

It's fixed for me! Thank you.

I couldn't see it on the small box too but I typed wolf and I pressed enter and I got results for "flow" (flower) in portrait instead of wolf.

It's back to normal now :)



DESIGNER
eclipse42
2021-06-15

@ajleroux, mk4gfx fixed, works great. Thank You.



DESIGNER
elwidy
2021-07-23

Is it just me or someone also got error message whenever doing Logo exam?

I tried different internet provider and still got the error sometimes



DESIGNER


DESIGNER
Genovius
2021-07-24

my new uploaded logo showed up 3 times
https://ibb.co/g77Ft0W



ADMIN
ajleroux
2021-07-26

elwidy, that error means the server was too busy at that moment to handle your request. It happens sometimes when there is an abnormal spike in traffic on LogoGround. When you see that error, wait a few seconds, then refresh the page.

Genovius, we have seen double uploads before, this is the first triple upload I am aware of. Is it possible that you clicked a button more than once? If not, then my guess is that it was a temporary connection issue between your computer and the LogoGround server. If you see a logo uploaded multiple times my recommendation is to delete all and then repeat the upload.



DESIGNER
Genovius
2021-07-26
Edited 2021-07-26 by Genovius permalink ANCHOR

@ajleroux, as the triple upload hasn't resolve yesterday, I'm deciding to delete the 2 others and left the other, today I've got the referred logo has been decline as "technical issue file missing".
So its better to delete all then reupload, thanks for the solution


Login or register to post.

85 posts
2249 views
Last post on 2021-07-26

Jump to last post

Post a reply

Start a new, separate topic

Back to forum index

Category: Feedback

Instagram Logo LogoGround on Instagram

Can we make LogoGround better for you?

Suggestion box Report a bug


© Copyright 2011-2021, Graphics Factory CC. All rights reserved. Use of this web site constitutes acceptance of the  User Agreement & Disclaimer. LogoGround.com is a division of Graphics Factory CC, SA., Reg Nr. 2008/121028/23

God First Policy